Keeping Your

Information Safe


 

What

As a part of a security update, effective April 19th, our servers will no longer serve traffic using versions of TLS (Transport Layer Security) prior to TLS 1.2. TLS  is a protocol that encrypts and authenticates data when it is transmitted between client browsers and servers.

 

Why

The PCI Security Standards Council, the organization responsible for setting credit card security standards, is requiring all payment processors and merchants to use TLS 1.2 and above as of June 30, 2018. We must make these changes to maintain our Level 1 PCI Compliance, which is a critical aspect of the service we provide for our community. All PCI Compliant services that accept credit cards — from personal banking websites to PayPal —  will be required to use TLS 1.2.

 

Impact

TLS 1.2 is not supported by certain, older browsers. This means that on April 19th parents and CampMinder users who are using old web browser versions released in 2014 and earlier may receive an error when trying to access CampMinder and CampInTouch.

Below is a list of supported browsers we recommend for the best experience:

Google Chrome 30 – 32 or higher

Mozilla Firefox 27 – 33 ESR 31.0 – 31.2

Microsoft Edge 11 or higher

Apple Safari 7 – 9 or higher

 

The Good News

Based on our analytics, we estimate fewer than 0.1% of users will be impacted by this change. While this number is very low, some users will be impacted, and we want you to be prepared for any questions that may arise. If you do receive calls from families indicating they receive an error message when accessing CampInTouch, or if any of your staff receive an error when attempting to access CampMinder, please ensure they are using a modern, supported browser from the list above.

If you have any questions, or if you’d like more information, please feel free to reach out!

 

The CampMinder Team